[BUG 1.37] Game causes system crash on first start

Please check bugs are not already reported, or listed as a pending fix!
Flacwby
Senior Line Worker
Senior Line Worker
Posts: 8
Joined: Sun Apr 16, 2017 9:19 pm

[BUG 1.37] Game causes system crash on first start

Postby Flacwby » Sun Nov 12, 2017 4:06 pm

For the past 10 or so updates, every time I start Production Line from Steam I get a system blue screen crash with exfat.sys errors. I know this error appears like it's a system issue, but ONLY happens when I try to start production line the first time. After the system crash I can start Production Line with no issue.

Windows 10, GTX 1080, i7-6700 @ 4.0GHz, 32GB RAM

Happy to provide any system info you may need.
User avatar
cliffski
Positech Staff
Positech Staff
Posts: 8010
Joined: Sat Feb 11, 2006 10:27 am
Location: UK
Contact:

Re: [BUG 1.37] Game causes system crash on first start

Postby cliffski » Mon Nov 13, 2017 11:55 pm

I've googled this a bit, and its definitely file system related. Thinking about your symptom, I'm guessing that production line is not installed on the C drive? (which BTW is fine its not on my dev PC either) and that maybe the 2 drives have different file systems? That should also be fine, but is there a possibility you have some errors on a drive? have you checked them for errors from windows (right click drive letter, select properties). The game writes some files (tiny ones) on the first startup each day, and in one case, once per update if you vote on priorities, so it might be that the drive location those files live in is corrupted.
Thats my best guess, as I haven't heard of anyone else with the same issue.
Flacwby
Senior Line Worker
Senior Line Worker
Posts: 8
Joined: Sun Apr 16, 2017 9:19 pm

Re: [BUG 1.37] Game causes system crash on first start

Postby Flacwby » Tue Nov 21, 2017 3:06 pm

But over 100 games and countless software apps, Production Line is the only one that causes this error. That's why I said it LOOKS like a system error but there's something in Production Line that I simply can't start the game. I'll continue to support you Cliff, but I can't play Production Line with it crashing my system every time I try to start. However If I'm the ONLY one with the issue, it's not worth fixing, I completely understand.
pderuiter
Line Supervisor
Line Supervisor
Posts: 15
Joined: Mon Nov 20, 2017 10:40 am

Re: [BUG 1.37] Game causes system crash on first start

Postby pderuiter » Tue Nov 21, 2017 7:11 pm

Correct me if i'm wrong, but it feels like you didn't even check? He is - based on your symptoms - telling you what sets production line apart from other games in this regard.
It writes files on first startup..which is exactly when your problem occurs.
TontoMcTavish
Type II Robot
Type II Robot
Posts: 66
Joined: Thu Nov 09, 2017 2:50 pm

Re: [BUG 1.37] Game causes system crash on first start

Postby TontoMcTavish » Tue Nov 21, 2017 7:38 pm

Flacwby wrote:But over 100 games and countless software apps, Production Line is the only one that causes this error. That's why I said it LOOKS like a system error but there's something in Production Line that I simply can't start the game. I'll continue to support you Cliff, but I can't play Production Line with it crashing my system every time I try to start. However If I'm the ONLY one with the issue, it's not worth fixing, I completely understand.


From experience you can get an exfat.sys error when you install any sort of software or driver. I've had it randomly appear on systems at work that I've installed 10 other pieces of software onto fine and that one bit made it crash, but then I can install the same piece of software of 10 more systems with no issues.

I'd generally say that it's a system error. Yes granted Production Line has caused the error but there is something on your system that is causing the issue. If everyone (or a significant proportion of people) were getting the error then I'd potentially look to the software but with only one user getting the issue then I'd be looking at the device personally.
Flacwby
Senior Line Worker
Senior Line Worker
Posts: 8
Joined: Sun Apr 16, 2017 9:19 pm

Re: [BUG 1.37] Game causes system crash on first start

Postby Flacwby » Sat Nov 25, 2017 3:18 pm

So I did track down this issue. The drive where Production Line is installed is NTFS, the drive where My Documents are stored was exFAT. I moved all 465 GB of data off the exFAT, reformatted to NTFS, restored all 465GB and now Production Line doesn't crash my system.

While this is a far reaching issue, again I do say that Production Line is the only game I've ever had that crashed because of this. Something in the way Production Line starts, then has to check the documents folder caused Windows 10 issues.

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 4 guests