[1.47] User created map is not loading

Please check bugs are not already reported, or listed as a pending fix!
maon
Junior Line Worker
Junior Line Worker
Posts: 3
Joined: Tue Mar 06, 2018 6:40 pm

[1.47] User created map is not loading

Postby maon » Mon Mar 19, 2018 6:34 pm

Hi,

when I am trying to start the game with game created by myself, the game crashed during factory creation. No error message found :( What I did wrong?

Thanks,
Ondrej
Attachments
Ondra2.txt
(12.97 KiB) Downloaded 57 times
User avatar
nutbarz
Supreme Robot
Supreme Robot
Posts: 113
Joined: Tue Jun 06, 2017 10:11 pm

Re: [1.47] User created map is not loading

Postby nutbarz » Tue Mar 20, 2018 1:36 am

Well, There is an Import Slot that seems to be outside of any zone, and a couple of the zones overlap. Those 2 things are causing some of the issues.

screenshot_19-03-2018_20-24-33.png
screenshot_19-03-2018_20-24-33.png (31.69 KiB) Viewed 3264 times
maon
Junior Line Worker
Junior Line Worker
Posts: 3
Joined: Tue Mar 06, 2018 6:40 pm

Re: [1.47] User created map is not loading

Postby maon » Tue Mar 20, 2018 6:28 pm

The issue is in the fact, that map size is 200*200 and the game creator let you create the space with coordinates ending with 200. However, because the numbering starts from 0. you should use only 199 as max number. This deserves some fix in future version.
User avatar
cliffski
Positech Staff
Positech Staff
Posts: 8143
Joined: Sat Feb 11, 2006 10:27 am
Location: UK
Contact:

Re: [1.47] User created map is not loading

Postby cliffski » Thu Apr 05, 2018 3:15 pm

Wow that map is.... kinda big. I blame factorio...
And yes, I need to work on the robustness of the map editor at some future point!

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 4 guests