Steam Users Problems Already - Getting Game to Work

For when your guns are jammed, your lasers are misfiring, or you forgot where you put that pesky trench ladder again...
rcard7878
Junior Line Worker
Junior Line Worker
Posts: 2
Joined: Fri May 18, 2012 2:07 am

Re: Steam Users Problems Already - Getting Game to Work

Postby rcard7878 » Fri May 18, 2012 2:22 am

Purchased through steam. Game looks as it will start then just shuts down. Never get past initial window. Here is a short video of what I am seeing: http://screencast.com/t/mZdWygQqbJ
hepcat
Junior Line Worker
Junior Line Worker
Posts: 1
Joined: Fri May 18, 2012 3:36 am

Re: Steam Users Problems Already - Getting Game to Work

Postby hepcat » Fri May 18, 2012 3:40 am

Games also stuttering for me and is quite unplayable right now. I sent off my dxdiag and the logs from GTB's debug directory to cliff. Hope that helps.
User avatar
cliffski
Positech Staff
Positech Staff
Posts: 7967
Joined: Sat Feb 11, 2006 10:27 am
Location: UK
Contact:

Re: Steam Users Problems Already - Getting Game to Work

Postby cliffski » Fri May 18, 2012 7:32 am

hmmm. as an experiment you could try renaming this folder:

\program files\steam\steamapps\common\gratuitous tank battles\data\sounds\music

to music2.
The game then won't be able to load or stream the music. It *may* give an error, but it may not, and that would rule out the streaming of sound from disk as the cause. Especially strange to hear GSB works fine on the same machine. if anything, GTB is more optimised than GSB.
Cfodder
Senior Line Worker
Senior Line Worker
Posts: 5
Joined: Thu May 17, 2012 10:34 pm

Re: Steam Users Problems Already - Getting Game to Work

Postby Cfodder » Fri May 18, 2012 11:29 am

Hi I tried this... when I did the music directory it still stuttered intermittently. I tried doing this to the entire sound directory, So sounds -> sounds2, and the stuttering stopped. I still have a bit of stuttering when I place units, but when the game actually starts there's not any breaks.

So yeah it looks to be audio streaming related =)
User avatar
cliffski
Positech Staff
Positech Staff
Posts: 7967
Joined: Sat Feb 11, 2006 10:27 am
Location: UK
Contact:

Re: Steam Users Problems Already - Getting Game to Work

Postby cliffski » Fri May 18, 2012 12:14 pm

Interesting... I shall see if there is anything obvious that could cause it. ironically, the ONE piece of code in the entire game that is not written 100% by me is the sound library, which is commercial middleware. That'll teach me eh?
User avatar
cliffski
Positech Staff
Positech Staff
Posts: 7967
Joined: Sat Feb 11, 2006 10:27 am
Location: UK
Contact:

Re: Steam Users Problems Already - Getting Game to Work

Postby cliffski » Fri May 18, 2012 12:25 pm

Just noticed this on the steam forums, so worth a try:

My game was REALLY laggy too when playing (music choppy, game stopping and skipping) and I hadn't ever had any problems like this before. Tried running in lower res, turning off graphical options, and windowed mode. Noticed a small improvement when I disabled STEAM overlay and then a FLAWLESS performance when I ran the .exe and didn't run it through STEAM. I suspect it may have some trouble running through STEAM.

Try running just the .exe from the "Steam\SteamApps\common\Gratuitous Tank Battles" folder. Worked wonders for me
Pierre70
Junior Line Worker
Junior Line Worker
Posts: 2
Joined: Fri May 18, 2012 1:54 pm

Re: Steam Users Problems Already - Getting Game to Work

Postby Pierre70 » Fri May 18, 2012 2:02 pm

I can confirm that running the game directly from its exe instead of through Steam solved my crashing problems. It might be worth stickying something about this until the Steam problems are sorted.
rcard7878
Junior Line Worker
Junior Line Worker
Posts: 2
Joined: Fri May 18, 2012 2:07 am

Re: Steam Users Problems Already - Getting Game to Work

Postby rcard7878 » Fri May 18, 2012 3:05 pm

Tried running the .exe in the location:
"Steam\SteamApps\common\Gratuitous Tank Battles" folder.

Received an error that the file "d3dx9_41.dll" was not installed. I noticed a file named "d3dx9d.dll" in the same directory as the .exe.
I simply renamed the file to the one listed as missing "d3dx9_41.dll" clicked on the .exe and it is working.
Cfodder
Senior Line Worker
Senior Line Worker
Posts: 5
Joined: Thu May 17, 2012 10:34 pm

Re: Steam Users Problems Already - Getting Game to Work

Postby Cfodder » Fri May 18, 2012 9:08 pm

Worked for me too! Awesome!
itcamefromouterspace
Type I Robot
Type I Robot
Posts: 40
Joined: Wed Jan 20, 2010 12:43 pm

Re: Steam Users Problems Already - Getting Game to Work

Postby itcamefromouterspace » Sat May 19, 2012 2:27 am

I was having a problem with launching the game and only having it run in task manager with no game screen.

I eventually got it to work by making a shortcut to the EXE and running it in comparability mode.

BTW, I am running WinXP x64.
I've seen things you people wouldn't believe. Attack ships on fire off the shoulder of Orion. I watched Cbeams glitter in the dark near the Tannhauser gate. All those moments will be lost in time...like tears in rain...Time to die

game name:TheBlackFleet
samvega
Junior Line Worker
Junior Line Worker
Posts: 1
Joined: Sun Jun 10, 2012 12:19 am

Re: Steam Users Problems Already - Getting Game to Work

Postby samvega » Sun Jun 10, 2012 12:22 am

I have the problem with the game not starting at all. When I try to launch it directly I get the d3dx9_41.dll error as well. I am running windows 7 64-bit. Could it be a problem with the 64 bit version of the game/steam maybe?
Solar
Senior Line Worker
Senior Line Worker
Posts: 9
Joined: Thu May 24, 2012 12:46 am

Re: Steam Users Problems Already - Getting Game to Work

Postby Solar » Sun Jun 10, 2012 9:26 am

Interesting. I have the steam version as well, but I had no problems what so ever with the game. :/
Solar
Senior Line Worker
Senior Line Worker
Posts: 9
Joined: Thu May 24, 2012 12:46 am

Re: Steam Users Problems Already - Getting Game to Work

Postby Solar » Sun Jun 10, 2012 9:30 am

samvega wrote:I have the problem with the game not starting at all. When I try to launch it directly I get the d3dx9_41.dll error as well. I am running windows 7 64-bit. Could it be a problem with the 64 bit version of the game/steam maybe?


Have you tried installing the latest DirectX? If yes and still won't work download the dll from here http://www.dll-files.com/dllindex/dll-f ... l?d3dx9_41
DRP
Junior Line Worker
Junior Line Worker
Posts: 1
Joined: Sun Jun 17, 2012 7:18 am

Re: Steam Users Problems Already - Getting Game to Work

Postby DRP » Sun Jun 17, 2012 7:51 am

I had the same problem, and running the .exe outside of Steam did the trick. Butter smooth now.
User avatar
cliffski
Positech Staff
Positech Staff
Posts: 7967
Joined: Sat Feb 11, 2006 10:27 am
Location: UK
Contact:

Re: Steam Users Problems Already - Getting Game to Work

Postby cliffski » Sun Jun 17, 2012 1:52 pm

DRP wrote:I had the same problem, and running the .exe outside of Steam did the trick. Butter smooth now.


any chance I could get you to help both me and valve work out what is causing the problem? neither of us can re-create it, so it would be really helpful if you could run a little test for us...
Thanks,

Return to “Support”

Who is online

Users browsing this forum: No registered users and 1 guest