Reset Tutorial?

WhiteHotLoveTiger
Junior Line Worker
Junior Line Worker
Posts: 2
Joined: Tue Dec 27, 2011 6:10 pm

Reset Tutorial?

Postby WhiteHotLoveTiger » Tue Dec 27, 2011 7:09 pm

I exited the game part-way through the setup part of the tutorial, and now when I restart the game and try to play the tutorial, it exits. I can go into the tutorial setup, but when I click on the button to start the battle, it quits without a message.

I tried deleting the game files and re-extracting the zipped files, but I still have the same problem. Is there some place where the game is storing some config files I could delete?
User avatar
urkle
Supreme Robot
Supreme Robot
Posts: 130
Joined: Thu Dec 15, 2011 2:27 pm
Contact:

Re: Reset Tutorial?

Postby urkle » Wed Dec 28, 2011 6:32 pm

Configuration files are all kept in your home directory under ~/.positech/GSB/

Also, check that you have the very lastest build (released 12-23).
Developing away on one of
Mac Pro Dual 2Ghz, 14GB RAM, Snow Leopard, nVidia 8800 512MB.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
WhiteHotLoveTiger
Junior Line Worker
Junior Line Worker
Posts: 2
Joined: Tue Dec 27, 2011 6:10 pm

Re: Reset Tutorial?

Postby WhiteHotLoveTiger » Thu Dec 29, 2011 4:12 am

thanks for the quick response. I was able to delete all of the game files and start from scratch. Unfortunately, I'm still getting the same behaviour. When I try to move on past the deployment screen, the game exits without a message. I checked for an error log in the /.positech/GSB/ folder, but didn't see anything. As much as I'd love to get it working on linux, I think I'm going to try firing it up in windows...
As for the version, I bought the game through the Humble bundle, so I've got 1:56:0. Is there a newer version than this?
User avatar
urkle
Supreme Robot
Supreme Robot
Posts: 130
Joined: Thu Dec 15, 2011 2:27 pm
Contact:

Re: Reset Tutorial?

Postby urkle » Thu Dec 29, 2011 2:09 pm

WhiteHotLoveTiger wrote:thanks for the quick response. I was able to delete all of the game files and start from scratch. Unfortunately, I'm still getting the same behaviour. When I try to move on past the deployment screen, the game exits without a message. I checked for an error log in the /.positech/GSB/ folder, but didn't see anything. As much as I'd love to get it working on linux, I think I'm going to try firing it up in windows...
As for the version, I bought the game through the Humble bundle, so I've got 1:56:0. Is there a newer version than this?


There have actually been 2 hotfixes during the course of the bundle the latest refreshed on the 23rd. So re-open that humble bundle email and goto your download page and fetch the latest installer. Yeah it still labels itself 1:56:0, but it now will create a build.log file in ~/.positech/GSB and should it crash it will create a crash.log in the same folder (and inform you of that fact)
Developing away on one of
Mac Pro Dual 2Ghz, 14GB RAM, Snow Leopard, nVidia 8800 512MB.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
Sidicas
Junior Line Supervisor
Junior Line Supervisor
Posts: 12
Joined: Sat Dec 17, 2011 5:02 am

Re: Reset Tutorial?

Postby Sidicas » Thu Dec 29, 2011 6:43 pm

urkle wrote:
WhiteHotLoveTiger wrote:thanks for the quick response. I was able to delete all of the game files and start from scratch. Unfortunately, I'm still getting the same behaviour. When I try to move on past the deployment screen, the game exits without a message. I checked for an error log in the /.positech/GSB/ folder, but didn't see anything. As much as I'd love to get it working on linux, I think I'm going to try firing it up in windows...
As for the version, I bought the game through the Humble bundle, so I've got 1:56:0. Is there a newer version than this?


There have actually been 2 hotfixes during the course of the bundle the latest refreshed on the 23rd. So re-open that humble bundle email and goto your download page and fetch the latest installer. Yeah it still labels itself 1:56:0, but it now will create a build.log file in ~/.positech/GSB and should it crash it will create a crash.log in the same folder (and inform you of that fact)


When it crashes, can you have it not do a pop-up? There is a problem that when the game is in full screen mode the pop-up will come up behind the game and you can't see or click on the pop-up.. and the game itself won't exit out until you click on the pop-up (which tells you a crash log has been generated), which you can't do because it's behind the game so you have to do a Ctrl+Alt+Backspace to restart X. I think I fixed all my crash problems by deleting a couple files in the game's libs directory as I haven't had pop-up problems in a while now. Also, the shader pop-ups don't happen any more and the game seems to run great now (even in fullscreen!), which makes me very happy!!

Off topic, I'm very surprised at how fast this game runs on my 6-year old hardware.. very very surprised.. The game is very nicely optimized for performance.

Also looking forward to buying DLC that runs under Linux without having to jump through hoops..

Return to “Linux Support”

Who is online

Users browsing this forum: No registered users and 1 guest