Page 1 of 1

Union mod bug.

Posted: Wed May 13, 2015 8:18 pm
by injusticekiller
Hey everyone.
I just recently fired up this game again.
Now that the sequel is out I'm sure there will be renewed interest, but its been a while for me, I just coincidentally decided to start GSB again. I didn't even know there was an outcasts expansion. :O
So, played it, it completely broke on me, decided to do a fresh install.
Then add mods.
The Union mod is installed, that's going back a ways, but I consider it one of the must haves.
Only trouble I'm having, when I click on create new ship or try to edit a design, the game freezes up.
I discovered that having a ship design from a previous now uninstalled mod causes the game to lock up completely from the get go.
So I didn't need to uninstall the entire thing I could have just gotten rid of some ship files -_-

Well maybe the same cause was behind this.
So, union ships. Deleted all the previous designs, ship builder now opens, so far so good.
But, I select any one of the hulls and it freezes again.
Strange, it is the only mod thats doing this.

Does anyone have any ideas?
I mean maybe yet another complete reinstall might fix it, but what if it happens again.

Re: Union mod bug.

Posted: Fri May 15, 2015 8:38 pm
by curtis.johnson
Hmmm. Normally Darkstar would've ninja'd it and you'd be on your way now, but he seems to have temporarily disappeared. In any case, I'll try what I can.

First of all, what other mods have you got installed?
Second of all, is it only selecting Union hulls that causes the problem, or is it any hull, vanilla and modded alike?
Third, exactly what version of the game are you running (Windows, Mac, Linux)?
And which build number? Current game build is v1.29.

Re: Union mod bug.

Posted: Fri May 15, 2015 10:03 pm
by Archduke Astro
injusticekiller:

You say that the game "freezes" for you. However, you have not mentioned if it is OR is not also displaying an error message.
If you are also seeing an error message at the time of the freeze, what does it say?

Re: Union mod bug.

Posted: Sat May 16, 2015 2:53 am
by darkstar076
curtis.johnson wrote:Hmmm. Normally Darkstar would've ninja'd it and you'd be on your way now, but he seems to have temporarily disappeared. In any case, I'll try what I can.

I am sorry to say that you are correct - Real Life has become really busy over here and it has completely destroyed the free time I use to have which was spent modding and ninja'ing the occasionally bug post.

The only thing that is making this enforced absence tolerable is that I know the forums are in good hands.

Archduke is correct, to make an assesment we need to know what DLC's are active and what is the error code that is occurring. (this will eliminate much of the guess work) in this case, what is the ship that causes the crash.

As a suggestion: if you navigate to \Documents\My Games\GratuitousSpaceBattles\debug\ and open debug.txt
The last few lines on the text file should give you the general direction on where it is crashing.

At a guess, i would say that Cens mod is calling for something that is not there or another mod is calling for something that is not in Union

Re: Union mod bug.

Posted: Wed May 20, 2015 9:22 pm
by injusticekiller
Hmm Curtis, I thought the game was at 1.65 by now.

Hmm, anyway.
To be clear, I have the latest version and all DLCs are active.
This is only happening with Union Ships, and does not happen with any other vanilla or modded vessel.
Also it simply freezes and I am obliged to use control alt and del to close the program, there is no error message.

This is the text from the debug. The designs being deleted are interesting but, the freeze is still happening, so I don't have much of a clue where to go from here.

Finished Initialising Sound Engine
Design [Gwazine] deleted because it was not valid with this version
Design [Magellan] deleted because it was not valid with this version
Design [MAN-08 Elmeth(EX)] deleted because it was not valid with this version
Design [prae_delta_wip] deleted because it was not valid with this version
Design [Unit elite FA Cruiser] deleted because it was not valid with this version
Start of SIM_Internet::OpenLink
End of SIM_Internet::OpenLink
SIM_Internet::DownloadFile(C:\Users\Agent M\Documents/My Games/GratuitousSpaceBattles/web/messages.txt)
SIM_Internet::DownloadFile ends
releasing D3D engine
D3D released
END DEBUG---

Re: Union mod bug.

Posted: Wed May 20, 2015 9:32 pm
by darkstar076
Hmmm, I cant see anything out of the ordinary there in the debug.
The version is the latest and all DLC's means that you should have all the files the Mod needs to operate.

Next Question: Is there an error.txt file in the same directory as debug.txt ?
If so, could you post the contents - if there is a large amount of text, used the CODE button

::Edit:: I am rather rusty, it shouldn't take me this long to figure out a problem with a mod.
At this point in time I am thinking turret mapping error, in the Union Mod Cen2050 only mapped 5 sets of turrets.
Now on it own this does not cause a problem as all the modules in Union only require 5 sets or turrets - HOWEVER if you have a mod that gives a weapon to all races and calls for a turret map that the Union race does not have, then the Union Mod will crash. (Which makes you think that its the Union Mod.)

Here is a post on what i think is a similar issue from the days when I was Modding Mad and Stress Free

In the event that I am on the right track, the fix is rather simple.

Re: Union mod bug.

Posted: Thu May 21, 2015 9:29 pm
by injusticekiller
Hah.
There was an error code being hidden by the game window and not popping up and it disappeared whenever I ctrl alt and deld.

I managed to catch it though.

What do you know, it IS a turret mapping error.

And I found the culprit. Pondafarr Industries, which makes weapons and target boosters available to all races.

Oh well have to do without it for now.
Have to see if it fixes the inexplicable freeze when loading certain maps as well.

I'm going to have to remove all the ship designs that made use of that or the game will crash from the get-go.
Blast and bother, I wish the code was a bit more bulletproof.

Re: Union mod bug.

Posted: Thu May 21, 2015 9:35 pm
by darkstar076
Glad you managed to catch it.

Just as a suggestion, you might find it quicker fixing the issue than to delete everything that was using the module.
If it is a turret mapping error, then all you have to do is add 4 lines of code to union.txt